Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Bandwidth Dashboard Impairment
Incident Report for Bandwidth
Resolved
We were able to complete a fix for the root cause and have confirmed this issue is resolved.
Posted May 16, 2023 - 16:12 EDT
Update
We're continuing to investigate the root cause of the issue and we'll provide further updates as they become available.
Posted May 16, 2023 - 10:50 EDT
Update
We’re continuing to investigate the root cause of the issue, but in the meantime, technical assistance has identified a workaround. We’ll continue to provide updates as they become available.
Posted May 15, 2023 - 20:58 EDT
Investigating
We're currently investigating an issue in the dashboard that is preventing some customers from creating new locations. Relevant teams are engaged and we'll provide further updates as they become available.
Posted May 15, 2023 - 19:03 EDT
This incident affected: Portals (Bandwidth Dashboard).