Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

BW US Inbound CNAM Delivery

Incident Report for Bandwidth

Resolved

We’ve confirmed stability and we’re considering this incident resolved.
Posted Apr 19, 2025 - 15:14 EDT

Monitoring

We’ve deployed a fix and mitigated impact at this time. We’re currently monitoring for stability.
Posted Apr 19, 2025 - 15:07 EDT

Investigating

We’re currently investigating possible issues with CNAM delivery on inbound calls to the BW US network. Relevant teams are engaged.
Posted Apr 19, 2025 - 14:30 EDT
This incident affected: Number Management Services (Inbound Calling - Caller ID Lookup (CNAM)).