Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Israel Calling Incident
Incident Report for Bandwidth
Monitoring
Teams are observing expected calling behaviors. We will monitor for continued stability.
Posted Nov 20, 2024 - 22:08 EST
Investigating
Bandwidth teams are investigating an incident impacting Inbound & Outbound voice call failures.
Posted Nov 20, 2024 - 21:42 EST
This incident affects: Israel Calling Services (Inbound Calling - Israel, Outbound Calling - Israel).