Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

911 Provisioning Delays

Incident Report for Bandwidth

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 08:55 EDT

Update

We continue to monitor for prolonged stability.
Posted Jun 18, 2025 - 08:51 EDT

Update

We continue to monitor for prolonged stability.
Posted Jun 17, 2025 - 14:42 EDT

Monitoring

Teams are observing expected processing behavior. We will continue to monitor for stability.
Posted Jun 17, 2025 - 12:52 EDT

Investigating

Teams are investigating delays in 911 provisioning requests. We are working to restore the expected provisioning processes.
Posted Jun 17, 2025 - 11:13 EDT
This incident affected: 9-1-1 Services (9-1-1 Provisioning Service).