Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

BW US Dashboard Impairment
Incident Report for Bandwidth
Resolved
We've confirmed stability and we're considering this incident resolved.
Posted May 22, 2023 - 13:32 EDT
Monitoring
We've pushed mitigation for the issue and dashboard function has returned to normal. We're currently monitoring for stability.
Posted May 22, 2023 - 12:38 EDT
Update
We're continuing to investigate the issue with the dashboard and we'll provide further updates as they become available.
Posted May 22, 2023 - 12:11 EDT
Investigating
We're currently investigating an issue causing intermittent latency and outages with the BW Dashboard. Relevant teams are engaged and we'll provide updates as they become available.
Posted May 22, 2023 - 11:04 EDT
This incident affected: Portals (Bandwidth Dashboard).