Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

LIDB Order delays

Incident Report for Bandwidth

Resolved

We’ve confirmed orders are processing as expected, and we’re considering this incident resolved at this time.
Posted Feb 13, 2025 - 15:29 EST

Monitoring

A fix has been implemented to process delayed orders. We're currently monitoring for completion. New updates should be processing normally at this time.
Posted Feb 13, 2025 - 13:22 EST

Identified

We’ve identified an issue causing delays in LIDB order processing. Relevant teams are engaged and we’ll advise once we have further updates.
Posted Feb 13, 2025 - 12:39 EST
This incident affected: Number Management Services (Line Feature Management).