Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.
Our partner has confirmed all activations have been processed, and we’re considering g the incident resolved at this time.
Posted Jul 25, 2025 - 21:14 EDT
Monitoring
Our partner has observed new activations are processing and they are working to clear the backlog. We’re currently monitoring their progress for completion.
Posted Jul 25, 2025 - 18:04 EDT
Update
We’re continuing to work with our partner on a fix for the issue.
Posted Jul 25, 2025 - 14:37 EDT
Update
We’re continuing to work with our partner on a fix for the issue.
Posted Jul 25, 2025 - 12:44 EDT
Update
We’re continuing to work with our partner on a fix for the issue.
Posted Jul 25, 2025 - 10:49 EDT
Identified
We’ve identified an issue with our partner causing delays in port order activation. Relevant teams are engaged and working to remediate the issue.
Posted Jul 25, 2025 - 09:14 EDT
This incident affected: Number Management Services (Number Porting).