Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Dashboard Order Delays
Incident Report for Bandwidth
Resolved
We've confirmed stability and consider this incident resolved.
Posted Nov 18, 2021 - 14:56 EST
Monitoring
A fix has been implemented for the problem causing the delays. Function has returned to normal at this time and we're monitoring for stability.
Posted Nov 18, 2021 - 14:02 EST
Investigating
We're currently investigating issues with orders completing in our dashboard. Relevant teams are engaged and we'll provide updates as they become available.
Posted Nov 18, 2021 - 11:54 EST
This incident affected: Number Management Services (New Number Ordering, Line Feature Management) and Portals (Bandwidth Dashboard).