Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Estonia Inbound Voice Incident
Incident Report for Bandwidth
Resolved
This incident has been resolved.
Posted May 31, 2023 - 18:57 EDT
Monitoring
Bandwidth has been advised routing has been restored. We are monitoring for expected network behavior.
Posted May 31, 2023 - 17:57 EDT
Update
Bandwidth teams have identified an off-network condition with our vendor that is impacting voice calling in Estonia. Teams are actively engaged with this vendor for a swift resolution.
Posted May 31, 2023 - 13:29 EDT
Update
Bandwidth teams have identified an off-network condition with our vendor that is impacting voice calling in Estonia. Teams are actively engaged with this vendor for a swift resolution.
Posted May 31, 2023 - 10:37 EDT
Identified
Bandwidth teams have identified an off-network condition with our vendor that is impacting voice calling in Estonia. Teams are actively engaged with this vendor for a swift resolution.
Posted May 31, 2023 - 09:33 EDT
Investigating
Bandwidth teams are investigating an incident impacting Inbound Voice calls in Estonia. Calls may not complete as expected in this region.
Posted May 31, 2023 - 08:53 EDT
This incident affected: Estonia Calling Services (Inbound Calling - Estonia).