Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

BW US Network Impairment Failing Callbacks
Incident Report for Bandwidth
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 17:19 EST
Update
We are continuing to work with our vendor.
Posted Nov 13, 2023 - 16:56 EST
Identified
We are aware of an industry-wide incident affecting Level3 telephone numbers. Users may experience delays on order statuses and activation issues. Our vendor is currently working on a fix.
Posted Nov 13, 2023 - 14:43 EST
This incident affected: Number Management Services (New Number Ordering, Number Porting).