Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Bandwidth Local Market Impairment - 624 - Duluth MN
Incident Report for Bandwidth
Resolved
Our carrier has completed all necessary repairs and Bandwidth can confirm all services are restored. This incident is being resolved.

Start Time: 03/07/2023 00:16 ET
Stop Time: 03/07/2023 04:54 ET
Posted Mar 07, 2023 - 06:24 EST
Identified
Our carrier is continuing to isolate the cause of this incident.
Posted Mar 07, 2023 - 05:28 EST
Investigating
We are experiencing an issue on the Bandwidth network affecting a small portion of local Inbound calls to your customers in this area. Inbound long-distance and Outbound calling are not impacted.

We are currently working with our carrier for resolution.
Posted Mar 07, 2023 - 01:24 EST
This incident affected: United States Local Market Status (624 - Duluth, MN).