Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Inbound Calling Incident - Finland

Incident Report for Bandwidth

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 14:10 EDT

Identified

Teams have identified the source of the of this incident and are working to restore expected calling behaviors.
Posted Jul 21, 2026 - 11:17 EDT

Update

We are continuing to investigate this issue.
Posted Jul 21, 2026 - 09:39 EDT

Investigating

Bandwidth teams are investigating an inbound calling incident impacting a small subset of Bandwidth App traffic for Finland destination calls. These calls may not complete as expected.
Posted Jul 21, 2026 - 08:37 EDT
This incident affected: Finland Calling Services (Inbound Calling - Finland).