Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Calling Incident - Mexico
Incident Report for Bandwidth
Resolved
Inbound traffic resumed in Mexico.

Start Time: 06:03 GMT
Stop Time: 07:50 GMT
Posted Mar 11, 2024 - 04:25 EDT
Investigating
Teams are investigating a calling incident in Mexico for inbound calling.
Posted Mar 11, 2024 - 03:19 EDT
This incident affected: Mexico Calling Services (Inbound Calling - Mexico).