Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Romania - Outbound Calling Incident

Incident Report for Bandwidth

Monitoring

Teams are observing expected calling behavior and will monitor for prolonged stability.
Posted Jul 01, 2025 - 13:39 EDT

Identified

Teams have identified the source of the incident and are working towards a resolution.
Posted Jul 01, 2025 - 13:28 EDT

Investigating

Bandwidth teams are investigating an incident where outbound calls from Romania are not completing as expected. Teams are working to restore expected calling behavior.
Posted Jul 01, 2025 - 10:28 EDT
This incident affects: Romania Calling Services (Outbound Calling - Romania).