Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Support & Ticketing Portal
Incident Report for Bandwidth
Resolved
We have seen our Support and Ticketing portal stabilize and consider this incident resolved.
Posted Sep 16, 2019 - 16:12 EDT
Monitoring
Bandwidth is seeing latency reduce on our Support and Ticketing portal. Our vendor continues to see recovery as well. Together we will continue to monitor this incident to ensure a full recovery.
Posted Sep 16, 2019 - 15:35 EDT
Identified
Our vendor has identified the source of latency with the Support and Ticketing Portal. All teams are actively working to resolve this incident. If you need assistance, please call us at 855-864-7776.
Posted Sep 16, 2019 - 15:01 EDT
Investigating
Bandwidth is investigating a service incident resulting in latency in our Support and Ticketing Portal. We have engaged all appropriate teams. If you need assistance, please call us at 855-864-7776.
Posted Sep 16, 2019 - 14:21 EDT
This incident affected: Support (Ticketing Support, Help Center).