Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Dashboard Delays
Incident Report for Bandwidth
Resolved
Bandwidth has confirmed dashboard is functioning at normal levels and considering this incident resolved.
Posted Oct 05, 2020 - 15:30 EDT
Monitoring
We have mitigated the latency issue at this time and are seeing processing times return to normal levels. We'll continue to monitor until we've confirmed the issue is resolved.
Posted Oct 05, 2020 - 14:32 EDT
Investigating
Bandwidth is currently investing a latency problem with the dashboard causing delays in most functions. The relevant teams are currently engaged and working toward a resolution.
Posted Oct 05, 2020 - 13:58 EDT
This incident affected: Portals (Bandwidth Dashboard).