Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Calling Incident - Greece
Incident Report for Bandwidth
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 19:32 EST
Identified
Bandwidth teams have identified an incident impacting inbound and outbound voice calls. Calls may not complete as expected.
Posted Dec 04, 2024 - 18:59 EST
This incident affected: Greece Calling Services (Inbound Calling - Greece, Outbound Calling - Greece).