Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Bandwidth Local Market Impairment - 620 - Rochester, MN
Incident Report for Bandwidth
Resolved
Final: Our carrier has completed all necessary repairs and Bandwidth can confirm all services are restored.
This incident is being resolved.

Start Time: 03/09/2023 05:01 GMT

Stop Time: 03/09/2023 12:15 GMT
Posted Mar 09, 2023 - 10:36 EST
Monitoring
We have observed services in this market have recovered and our carrier is finalizing repairs. This incident will be resolved when we confirm all repairs are complete
Posted Mar 09, 2023 - 08:21 EST
Identified
Our carrier has identified a fiber cut and is working to complete repairs.
Posted Mar 09, 2023 - 05:00 EST
Investigating
We are experiencing an issue on the Bandwidth network affecting a small portion of local Inbound calls to your customers in this area. Inbound long-distance and Outbound calling are not impacted.

We are currently working with our carrier for resolution.
Posted Mar 09, 2023 - 00:58 EST
This incident affected: United States Local Market Status (620 - Rochester, MN).