Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

BW US/BWI Dashboard Order Processing Delays
Incident Report for Bandwidth
Resolved
We’ve confirmed stability and considering this incident resolved.
Posted Feb 22, 2024 - 14:02 EST
Monitoring
Processing times have recovered at this time and we’re currently monitoring for stability.
Posted Feb 22, 2024 - 13:10 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2024 - 12:31 EST
Investigating
We're currently investigating an issue causing delays in dashboard order completion. This is affecting all order types processing through the dashboard. This is unrelated to the current incident affecting off-net port completion, and is not affecting orders submitted via API.
Posted Feb 22, 2024 - 12:07 EST
This incident affected: Portals (Bandwidth Dashboard).