Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Inbound Calling Incident - Philippines

Incident Report for Bandwidth

Update

Bandwidth teams continue to investigate this incident alongside the impaired provider.
Posted Nov 06, 2025 - 14:31 EST

Investigating

Bandwidth teams are investigating an inbound calling incident to the Philippines where inbound calls are intermittently not completing as expected.
Posted Nov 06, 2025 - 10:05 EST
This incident affects: Philippines Calling Service (Inbound Calling- Philippines).