Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Inbound Calling Incident- Puerto Rico

Incident Report for Bandwidth

Update

Bandwidth team have identified the source of the incident and are working with the impaired vendor to restore expected calling behaviors to Puerto Rico. Updates will be provided as they become available.
Posted Aug 29, 2025 - 21:40 EDT

Identified

Bandwidth team have identified the source of the incident and are working with the impaired vendor to restore expected calling behaviors to Puerto Rico. Updates will be provided as they become available.
Posted Aug 29, 2025 - 18:33 EDT

Investigating

Both teams are investigating intermittent inbound call failures to Puerto Rican destinations.
Posted Aug 29, 2025 - 16:10 EDT
This incident affects: Puerto Rico Calling Services (Inbound Calling - Puerto Rico).