Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Puerto Rico Inbound Traffic Incident
Incident Report for Bandwidth
Resolved
We’ve confirmed stability and we’re considering this incident resolved.
Posted Apr 26, 2024 - 19:16 EDT
Monitoring
Between the hours of 8am-4pm ET today 4/26 customers may have experienced inbound call failures to Puerto Rico. Traffic is functioning normally at this time and we’re monitoring for stability.
Posted Apr 26, 2024 - 19:01 EDT
This incident affected: Puerto Rico Calling Services (Inbound Calling - Puerto Rico).