Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Bandwidth Support and Ticketing Portal
Incident Report for Bandwidth
Resolved
Bandwidth’s ticketing vendor has mitigated this impairment. Our teams will continue to monitor, however, we consider this incident resolved.
Posted Jun 07, 2018 - 13:13 EDT
Investigating
Bandwidth’s ticketing vendor is currently experiencing a service impairment affecting our Support and Ticketing Portal. Your Bandwidth Support Team can still be reached by phone at: 855-864-7776 to assist. We are working with our vendor to restore Support and Ticketing Portal
Posted Jun 07, 2018 - 12:35 EDT