Welcome to Bandwidth's home for network updates. Here, you will find information pertinent to outages, scheduled maintenance, and general notices with real-time updates.

Incidents across areas

Inbound Calling - Mexico

Incident Report for Bandwidth

Resolved

We’ve confirmed stability and we’re considering this incident resolved.
Posted Mar 05, 2025 - 19:59 EST

Monitoring

A fix has been implemented and traffic has resumed normal function. We’re currently monitoring for stability.
Posted Mar 05, 2025 - 18:46 EST

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 17:55 EST

Investigating

Bandwidth Teams are investigating an incident impacting Inbound Calling to Mexico, where no ring-ringback is observed.
Posted Mar 05, 2025 - 16:31 EST
This incident affected: Mexico Calling Services (Inbound Calling - Mexico).